[MM1.5] Android system requirements

Last Updated: Jan 23, 2017 02:13PM PST
Mukurtu Mobile 1.5, released in March 2014, was the app's first release supporting Android, developed for both phones and tablets.

Mukurtu Mobile 2.0, released in July 2014, supports Android 2.3.6 (distributed since September 2011) and all following versions on phone, Android 3.0 (distributed since February 2011) and following versions on tablet.

At this time, the Android app only works with Mukurtu CMS 1.5.

Get the app for Android or read more on our support page.