[MM1.5] iOS System Requirements

Last Updated: Jan 23, 2017 02:13PM PST
Mukurtu Mobile has supported iPhone since its 1.0 beta release in October 2012.
Mukurtu Mobile 1.5, released in March 2014, was the app's first release supporting iPad. Mukurtu Mobile 2.5, released in August 2015, currently works on iPhones and iPads installing iOS8 and following.

Supported iOS devices:
  • iPhone 4S (distributed since October 2011)
  • iPhone 5
  • iPhone 5C
  • iPhone 5S
  • iPod touch 5th generation
  • iPad 2 (distributed since March 2011)
  • iPad with Retina Display
  • iPad Air
  • iPad Mini
  • iPad Mini with Retina Display
Get the app for iOS or read more on our support page.